Necessary Configuration
- Minimum CW version to use mobile app is 7.5.3.11.
- Sites must have Use_Schedule_In_Out set to FALSE, otherwise when the Charge Code List Request message is sent, user will be clocked In automatically. If I click to add cc or task on the mobile apps but don't actually finish what I'm doing, there's still going to be an in punch for me if “use schedule in out” is set to true.
- When this setting is set to True users may get a "Server Error" message on their device and see an out punch or duplicate punch on their timesheet.
Sample Image of Duplicate Punches when set to True:
- This can be done by logging into the customer's site as superadmin, navigating to Administrator > Configuration, and then clicking "Go to Advanced Settings..." at the bottom left. From there begin typing "Use_" without quotation marks into the filter for property or description and it should pop up.
- Any employee the customer would like to have access via the mobile app will need a Device ID. Most customers copy the Employee ID to the Device ID field to make it easier.
Important to Know/Troubleshooting
- Mobile apps are using existing clock messages; most behavior found on clocks are duplicated in the app.
- When a user logs into the app, it will automatically create a timesheet for that user. This is because of how our clock messaging for User Info works. There’s no changing this. In the future, when we get to make a real API, then this won’t be an issue. However, it’s something to know for now.
- iOS clock in/out time with location tracking can take up to 10 sec.
- When the Clockwise Site has "show cc description on in punch" enabled, apps will not show cc description.
- Not intended for Webclock-Only users right now.
- The app's transaction log tracks timesheet saves, submits, and unsubmits, but does not detail what changes were saved/submitted.
- Apps use Charge Codes for leave request (Like Clocks).
- If a timesheet is not properly loading or the app is crashing on the device when loading a timesheet, one possible issue may be that the site’s timesheet period or start date was changed and the historical timesheets were not deleted from the site. There will be noticeable issues on the front end as well if this is the case.
Differences Between iOS and Android
- Android will allow the user to select a photo for upload AND to take a picture from the app directly.
- iOS will allow the user to select a photo for upload but not to take a picture from the app directly.
KNOWN ERRORS and RESOLUTIONS
1. Login FailedError During Security Check, please try again.
Known bug: MOBI-202
Causes:
Solutions: The current workaround is that the user needs to close the app in the background.
You can see the ‘recreate steps’ in that JIRA but they would need to press the "Overview" button which is the button on the left with the three vertical lines. Then find the app in the list of apps they have open in the background and swipe the app up to close it.
But yeah just let them know they will need to make sure they either close out of the app, or sign out using the sign out button in the navigation menu on the app. (Press the three horizontal bars on the top right of the screen)
2. Login Error You are only authorized to login via the Web Clock feature on the website
Causes:
Solutions:
3. Server Error or In/Out Already Exists
Causes: Use schedule in out is set to true OR the CW site rounding is set to day
Solutions: Set use_schedule_in_out to false in advance config setting
Set CW site rounding to punch or pair
4. No Value Found
Causes: Currently, some employees that do not have a timesheet created for the current period experience a "No Value Found" error when signing in despite the profile being setup correctly.
Solutions: At present the solution to this matter would be to navigate to what would be the example employee's timesheet, then save. You do not have to add hours as this will create the timesheet in the database and allow a mobile app sign in.
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